Investigating Elevated Error Rates with Authentication
Incident Report for Gainsight
Postmortem

Incident:
Between 16:14 and 17:16 UTC on the 13th of March, CS-US1 customers may have experienced errors while trying to log into the application. Users who were already logged into NXT tenants or using the SFDC version of Gainsight were not affected. Others may have experienced slowness while logging in.

Root Cause: This was caused by a widespread network connectivity issue with an upstream Cloud Provider tied to Authentication Services used by our applications.

Recovery Action: While the Service Provider evaluated manual failover, the network issue at Cloud Provider level was resolved before further action was required. ‌

Preventive Measures:
The upstream Service Provider is reviewing their detection logic and has enhanced their monitoring mechanisms to identify issues like this moving forward.

Posted Aug 11, 2023 - 04:18 UTC

Resolved
This incident has been resolved. We will relay RCA details as they become available.
Posted Mar 13, 2023 - 17:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2023 - 16:37 UTC
Investigating
We have identified an issue with our authentication service provider which may cause errors for some users while accessing the Gainsight NXT application.

Users who are already logged into NXT tenants or using the SFDC version of Gainsight are not affected. Others may experience slowness while logging in.

We are closely monitoring and will post updates as they are available.
Posted Mar 13, 2023 - 16:14 UTC
This incident affected: Gainsight CS - US1 Region (Gainsight CS US1 Application) and Gainsight CS - US2 Region (Gainsight CS US2 Application).