Gainsight CS - US1 - Latency
Incident Report for Gainsight
Postmortem

Incident:
26th August, 2024: Some customers may have experienced elevated levels of latency while using our CS-US1 application.

Root Cause:

  • There was an increased frequency of database calls tied to a recent hotfix. The increased traffic was intermittent but led to slower API response times and thus impacted customer experience from browser.
  • Customers in CS-US1 may have experienced the latency while browsing. Impact was relatively less for our CS-US2 and CS-EU regions.
  • Sanity testing in lower environments did not initially produce this issue which was only observed with production traffic in US1.

Recovery Action:
Once the source was identified, a subsequent fix was applied which restored performance to expected levels.

Preventive Measures:
The mentioned fix has resolved this issue. We will continue to review and learn from issues like this in effort to provide the best possible customer experience. Please contact support@gainsight.com if there are any questions.

Posted Sep 04, 2024 - 05:11 UTC

Resolved
The issue is resolved. Systems are back to their normal performance level.
We will share the RCA as soon as it is available.
Posted Aug 27, 2024 - 13:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 27, 2024 - 04:36 UTC
Update
We are keeping the incident open at this time to monitor for further issues.
Posted Aug 26, 2024 - 19:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2024 - 18:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 26, 2024 - 17:19 UTC
Investigating
We are investigating reports of latency with loading pages in CS-US1. We will post further updates as we have more details.
Posted Aug 26, 2024 - 17:06 UTC
This incident affected: Gainsight CS - US1 Region (Gainsight CS US1 Application).