CS - US1: Investigating Elevated Error Rates

Incident Report for Gainsight

Postmortem

We experienced a brief period of degraded API performance on the 29th of January, between 20:47 and 21:25 UTC . Our monitoring systems detected the issue, and the team quickly identified and resolved it.

The service was fully restored, and we’ve taken steps to strengthen safeguards and prevent similar issues in the future. We appreciate your patience while we worked to resolve this.

Posted Jan 30, 2026 - 06:55 UTC

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 22:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2026 - 21:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 29, 2026 - 21:26 UTC

Investigating

We are investigating a sudden increase in error rates which may lead to degraded performance or service interruption.
Posted Jan 29, 2026 - 20:54 UTC
This incident affected: Gainsight CS - US1 Region (Gainsight CS US1 Application, US1 Rules Engine Queue, US1 Data Processor Queue, US1 Data Ingestion Queue, US - Insight Agent - Powered by Staircase AI).