Gainsight CS - US1 - Degraded Performance
Incident Report for Gainsight
Postmortem

Incident:
12th February, 2024: Between the times of 2:30 PM and 3:30 PM UTC, some CS-US1 customers may have experienced intermittent delays in application load times.

Root Cause:
The issue was result of query enhancements introduced in the latest release. This caused unexpected API latency which affected multiple areas of the CS-US1 application.

Recovery Action:
Once the source was identified, the related functionality was rolled back which restored performance to expected levels.

Preventive Measures:
This issue was previously undetected as it only occurred with very high concurrency. We are modifying testing methods and monitoring solutions to detect issues like this moving forward. We will continue to review and learn from issues like this in effort to provide the best possible customer experience. Please contact support@gainsight.com if there are any questions.

Posted Feb 16, 2024 - 14:41 UTC

Resolved
Between the times of 2:30 and 3:30 PM UTC, some customers may have experienced intermittent delays in application load times. We have identified the affected nodes and have resolved the issue.
Posted Feb 12, 2024 - 14:30 UTC