Insight Agent - Powered by Staircase AI - Availability issues

Incident Report for Gainsight

Resolved

This incident is resolved.
Posted Nov 18, 2025 - 15:53 UTC

Monitoring

A fix has been implemented by Cloudflare and services are back to normal. We will continue to monitor.
Posted Nov 18, 2025 - 14:46 UTC

Investigating

Insight Agent - Powered by Staircase AI is experiencing availability issue due to service degradation at CloudFlare
We are investigating further and will provide updates as available.
Posted Nov 18, 2025 - 14:13 UTC
This incident affected: Gainsight CS - US1 Region (US - Insight Agent - Powered by Staircase AI) and Gainsight CS - EU Region (EU - Insight Agent - Powered by Staircase AI).