CS-US1 - Degraded performance in Timeline
Incident Report for Gainsight US
Postmortem

Incident:
Some customers may have experienced degraded performance in CS-US1 Timeline services between 15:44 and 15:48 UTC on the 28th of July.

Root Cause:
A memory issue on multiple web servers led to Timeline becoming unresponsive intermittently, while other servers in the pool continued to serve traffic.

Recovery Action:
Monitoring systems alerted engineers of a memory issue on Timeline web servers. Engineers quickly made adjustments and redeployed Timeline web servers as a temporary fix.

Preventive Measures:
A permanent hotfix will be deployed in our next release window.

Posted Aug 11, 2023 - 14:33 UTC

Resolved
Some customers may have experienced slowness or errors while trying to load Timeline in CS-US1. Engineers responded quickly to restore services. We will post root cause details as they become available.
Posted Jul 28, 2023 - 16:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2023 - 15:53 UTC
Investigating
We are investigating performance issues related to Timeline and will update as we have more information.
Posted Jul 28, 2023 - 15:49 UTC
This incident affected: Gainsight CS - US1 Region (Gainsight CS US1 Application).